128 private links
Avoir les touches "Début" et "Fin", correctement mappée sur MacOS.
You could remap home and end by creating ~/Library/KeyBindings/ and saving a property list like this as DefaultKeyBinding.dict:
{
"\UF729" = moveToBeginningOfLine:; // home
"\UF72B" = moveToEndOfLine:; // end
"$\UF729" = moveToBeginningOfLineAndModifySelection:; // shift-home
"$\UF72B" = moveToEndOfLineAndModifySelection:; // shift-end
}
Most of the keybindings for editing text in OS X are defined in /System/Library/Frameworks/AppKit.framework/Resources/StandardKeyBinding.dict.
Setp 1: On terminal
diskutil list
identifying usb drive in terminal
The name of the USB drive should be something like /dev/disk0, ./dev/disk1, /dev/disk2.
Step 2: Identify your disk name and unmount it with the following command:
diskutil unmountDisk /dev/disk2
Step 3: Next, type in and enter the following command that will start to burn your ISO to USB:
sudo dd if=/path/to/win-iso-file of=/dev/disk2 bs=1m
Step 4: You may need to wait 10-15 minutes to an hour to let Mac burn iOS to USB. Afterward, enter this command to eject your volume successfully:
diskutil eject /dev/disk2
Extrait:
"""
Caffeinate can prevent sleep for a certain length of time, measured in seconds. The following command prevents the Mac from sleeping for one hour - 60 x 60 seconds.
caffeinate -t 3600
Here is a command that prevents anything from sleeping for one hour:
caffeinate -dismu -t 3600
d = Prevent the display from sleeping
i = Prevent the system from idle sleeping
s = Prevent the system from sleeping on mains power
m = Prevent hard disks from sleeping
u = Says the user is active
"""
Copier des fichiers + répertoires, sans déplacer les fichers de plus de 4Go.
Utile pour copier atomiquement, donc sans lien des uns aux autres, des fichiers vers un disque en FAT32, en respectant les dossiers de manière récursive.
Exemple sous MacOS :
caffeinate rsync -rv --update --max-size=4G /path/in/local/ server:~/project/
L'APFS remplace l'HFS+ sur MacOS
Comment éviter que Skype démarre automatiquement sur MacOS.
Ce logiciel est excellent pour rechercher dans plein de fichiers PDF.
Comme un GREP et dans des PDF.
Application indispensable !
Configurable à souhait, cette mini-application permet de remplacer des textes tapés n'importe quand par un autre texte.
Exemple:
Taper n'importe où ":date" et il remplace ce texte par la date du jour.
C'est compatible Windows, MacOS et Linux.
Il existe plein d'extensions en configuration vraiment agréables et efficaces.
Bref de l'EXCELLENT TRAVAIL !
Un gros bravo !
Comment retirer la notification de l'icône préférence (preference) sous MacOS sur la mise à jour.
$ defaults write com.apple.systempreferences AttentionPrefBundleIDs 0
$ killall Dock
Comment connaître la fonte (police de caractère) d'un PDF sous MAC ?
Commande sous Mac :
strings /path/to/document.pdf | grep -i FontName
Pour MacOS.
Pour placer un terminal à un endroit spécifique du Finder.
Mettre un raccourcis ici:
System Preferences > Keyboard > Shortcuts > Services
Pour faire fonctionner Grisbi sous High Sierra, faire ceci :
"""
cd /Applications/Grisbi.app/Contents/Resources/lib
sudo mv libz.1.dylib libz.1.dylib.original
"""