127 private links
Avoir les touches "Début" et "Fin", correctement mappée sur MacOS.
You could remap home and end by creating ~/Library/KeyBindings/ and saving a property list like this as DefaultKeyBinding.dict:
{
"\UF729" = moveToBeginningOfLine:; // home
"\UF72B" = moveToEndOfLine:; // end
"$\UF729" = moveToBeginningOfLineAndModifySelection:; // shift-home
"$\UF72B" = moveToEndOfLineAndModifySelection:; // shift-end
}
Most of the keybindings for editing text in OS X are defined in /System/Library/Frameworks/AppKit.framework/Resources/StandardKeyBinding.dict.
Cela pourra toujours servir.
Via : https://lehollandaisvolant.net/?mode=links&id=20230321125717
Explication de code en Python.
Part1
#define FOO(x) do { foo(x); bar(x); } while (0)
if (condition)
FOO(x);
else
....
Part 2
do {
// do something
if (error) {
break;
}
// do something else
if (error) {
break;
}
// etc..
} while (0);
Setp 1: On terminal
diskutil list
identifying usb drive in terminal
The name of the USB drive should be something like /dev/disk0, ./dev/disk1, /dev/disk2.
Step 2: Identify your disk name and unmount it with the following command:
diskutil unmountDisk /dev/disk2
Step 3: Next, type in and enter the following command that will start to burn your ISO to USB:
sudo dd if=/path/to/win-iso-file of=/dev/disk2 bs=1m
Step 4: You may need to wait 10-15 minutes to an hour to let Mac burn iOS to USB. Afterward, enter this command to eject your volume successfully:
diskutil eject /dev/disk2
Des problèmes de Floating point float & double.
Très intéressant.
Editeur en ligne pour les float <=> int en bit à bit.
Très bien pour faire des schémas, à partir d'un déclaration.
Quand on a une ancienne release de Ubuntu, qu'on veut faire un "apt update" ou "apt install", mais qui n'est plus reconnue.
C'est nul en terme de sécurité mais lorsqu'on a une machine en interne, on n'a pas le choix.
Err + Ign lors d'un "apt update"
""""
$ sudo sed -i -r 's/([a-z]{2}.)?archive.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
$ sudo sed -i -r 's/security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list
"""
Toutes les commandes spéciales pour Doxygen.
Petite astuce en langage C pour afficher un nombre de caractères précis dans un printf.
// Only 5 characters printed. When using %.s, add a value before your string variable to specify the length.
printf("Here are the first 5 characters: %.s\n", 5, mystr); //5 here refers to # of characters
Cela évite un "snprintf".
Peut-être y a--t-il encore mieux ?
Très bons conseils pour Firefox.
Extrait :
"""
dom.event.clipboardevents.enabled à false (dans la page aboug:config)
dom.event.contextmenu.enabled=false : Interdit le blocage du click-droit
dom.event.dragexit.enabled=false : Interdit de déclancher des popup/popin lorsque votre souris sort du site
"""
Comment travailler avec python et Excel !
Tout pour unitest en python.
assertEqual
assertTrue
assertGreater
asserLess
assertIsNone
assertIsInstance
assertIn
assertNotIn
Oh que c'est bien !
Merci beaucoup.
J'ai déjà eu ce sentiment : "Le choc est d’autant plus grand quand nous devons utiliser l’ordinateur de quelqu’un d’autre."
Merci encore Framablog pour ce billet résumé.
Site qui permet de contruire sa propre ligne de commande pour 7z (7zip).
Exemple :
7za a -t7z -mx0 -mhe -pPASSWORD final.7z source/
--> STORE ONLY + protection par password + cryptage des noms de fichier
Je ne m'en souviens jamais...
du -sh -- * | sort -h
Extrait:
"""
Caffeinate can prevent sleep for a certain length of time, measured in seconds. The following command prevents the Mac from sleeping for one hour - 60 x 60 seconds.
caffeinate -t 3600
Here is a command that prevents anything from sleeping for one hour:
caffeinate -dismu -t 3600
d = Prevent the display from sleeping
i = Prevent the system from idle sleeping
s = Prevent the system from sleeping on mains power
m = Prevent hard disks from sleeping
u = Says the user is active
"""